Categorized in: 

Ready for the Elevate Upgrade? How about your computer?

You may need to install new programs to support HCM upgrades.

 

To help us make a seamless transition to HCM this fall, we need you to check if you have the correct browsers and applications configured on your desktop.

 

Read the Supported Elevate Desktop Configurations page to review the required browsers and applications, and make sure they're installed on your computer. If not, your campus service desk can help you install the correct versions.

Important note on nVision and BI Publisher

If your campus uses Office 365, you must have the desktop version of Word and Excel installed to work with nVision and BI Publisher. Word and Excel for Mac will not support these applications.

Questions?

If you have any questions about the desktop configuration requirements, or the Elevate project in general, email system.training@cu.edu.

Add new comment